Install/Uninstall problem with version 1.0
  • MaxMax June 2012

    I ran into a specific problem while trying to update xJSFL to version 1.0, I thought you might want to know about it. Context: Flash CS5.5 *and* CS6, OSX 10.7.4 - with existing installation of the previous xJSFL release in /Developer/xJSFL

    First thing that happened is the installer complained about needing a document open before proceeding - not sure where that call was from exactly (see log at the bottom). My (frustrating) experience with jsfl would point to something along the lines of a document check (dom != null) in a context where it's not necessary. Searching for "REMOVING OLD COMMANDS..." brought me to install.jsfl, which I modified to trace values. I found it seems to go belly-up here (line 148)

    var uris = Utils.getURIs(fl.configURI + 'Commands/xJSFL/');

    What I think happened is the "xJSFL" folder was successfully deleted the first time around, before I was asked to open a document. Then when trying to find the same folder to clean up an existing installation which was already cleaned up (at least in part), an error is returned. I added an empty xJSFL folder in Configuration/Commands, and the next time I ran the installer, it successfully completed (without having a document open -- although the installer creates an empty one and leaves it there)

    A note: my first update on a separate computer (same OS and Flash version) was successful on the first try. I can't remember if I had a document open or not, but I'm assuming I did. 

    Here's how I was able to reproduce the bug at least three times:

    - run /Developer/xJSFL/core/jsfl/install/uninstall.jsfl

    - restart Flash CS5.5/CS6

    - run /Developer/xJSFL/install.jsfl (without a FLA open)

    Additional info: I noticed that uninstall.jsfl sometimes leaves the Commands/xJSFL folder and its contents in the file system.

     Congrats on the tremendous amount of work you put into this project. I'm very impressed, especially by the efforts that went into the Komodo integration/plugins.




    > xjsfl: INSTALLING xJSFL...

    > xjsfl: loading proxy classes...

    > xjsfl: loading xjsfl...


    > xjsfl: LOADING CORE CLASSES...

    > xjsfl: loading library: Globals

    > xjsfl: loading library: Utils

    > xjsfl: loading library: URI

    > xjsfl: loading library: URIList



    > xjsfl: added 25 search paths for "{core}jsfl/libraries/Macintosh HD/Developer/xJSFL/core/"

    > xjsfl: loading library: JSFLInterface

    > xjsfl: loading library: XUL

    > xjsfl: loading library: File

    > xjsfl: loading library: Class

    > xjsfl: loading library: FileSystemObject

    > xjsfl: loading library: Folder

    > xjsfl: loading library: XML

    > xjsfl: loading library: String

    > xjsfl: loading library: SimpleTemplate

    > xjsfl: loading library: XULControl

    > xjsfl: loading library: XULEvent

    > xjsfl: loading library: Output

    > xjsfl: loading library: Table

    > xjsfl: loading library: PropertyResolver



    The following JavaScript error(s) occurred:


    Open a Flash document (FLA) before running this script.



    > xjsfl: INSTALLING xJSFL...

    > xjsfl: loading proxy classes...

    > xjsfl: loading xjsfl...

    The following JavaScript error(s) occurred:


    > xjsfl: LOADING CORE CLASSES...

    The following JavaScript error(s) occurred:


  • DaveDave June 2012

    Hey Max,

    Thanks very much for reporting these bugs - I only really test on 2 machines (PC and Mac) so it's good to get wider feedback.

    Yep, CS5 and CS6 are buggers for error messages. In CS4 Flash usually tells you what is going on, but in later versions it's anyone's guess, as Flash gobbles the actual error messages:

    As such I still develop JSFL on CS4.

    My hunch is that it's the way xJSFL is working with URIs on a Mac that's causing these errors - I'll take a look at your process in the next day or two and will report back.

    And thanks for your kind words! I'm hugely relieved to have finally got everything released. Although it's nearly killed me. No more open source projects for a while I think!


  • DaveDave July 2012
    Not sure if you want to check the 1.01 version. A bunch of updates and the bit that handles deleting commands was re-written
  • MaxMax July 2012

    Hello again,

    Nice job! 1.01 appears to behave like it should with the Commands folder :)

    Are you intentionally deleting External Libraries folder when uninstalling if it's empty? (CS5.5/CS6) It's left alone if it contains something else, but I'm afraid it could cause conflicts with other plugins/MXPs which don't check for an existing folder before copying files.

  • DaveDave July 2012

    Oooh. I didn't think it was? I'll double-check and make sure it's not. Thanks for the info!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID Sign In with Google Sign In with Twitter

Sign In Apply for Membership